Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.

DLC Avorion Into the Rift Out Now!

Now available on Steam!

Bug in Tutorial: Cant recruit crew because I am not docked


Recommended Posts

Hello All together

Comming back to Avorion 2.0 a replayed the tutorial to bring me up to speed. I encountered a bug, although I am pretty sure, I know, what I should be doing.

Version: Latest version. New Galaxy. normal mode and normal difficulty, german language

Bug: At some point in the tutorial, after loosing your ship and building your own new one, you have to recruit crew. Todo that, you have to dock. When flying to the dock, with or without using the tractor beams at says that you are docked and you can interact with dock (using F). The station is selected too. In the following tutorial window, which teaches you how to recruit crew, I cant recruit any amount of people, because it says, that I must be docked to the station. After multiple tries and getting real close it still does not work as it tells me.


- Could not reproduce myself. Restarted the Galaxy and followed the tutorial and i just worked as intended

- Two Things where different. The station design was different (other seed). I used less hotkeys the second time.


Although this happened only once to me, please check for bugs.


Link to comment
Share on other sites

  • 1 year later...

I have been playing awhile and see this constantly, it's like the stations are not calculating the docks properly and 'recalculate' them but get stuck at the 'recalculate' part until you nudge the entire station and then set your ship to dock in N sector overview mode. When you do that it will force the station in question to re generate it's docks and give you a valid dock properly.

After that, I just Backspace out of the autopilot command and dock normally or just wait and let the autopilot do its thing.

Can confirm this is happening to about 10-15% of the stations in both single and multiplayer I've tried to use. Once I get it to go away it doesn't seem to have happened again.

Really strange that it's acting like these stations lost all their docks and have to generate new docks like this..


2.0 has been really buggy.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...