Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.

DLC Avorion Into the Rift Out Now!

Now available on Steam!

Windows 10 warning about "possible UI scaling issue"


Recommended Posts

Hi! I'm using the Steam version of Avorion on Windows 10 Home, and I've been seeing a consistent warning pop up every time I run the program since I bought the game in December, 2020. The warning doesn't appear to cause any problems with running the game in either single- or multi-player mode, it's just an annoying pop up that I have to click through every time I want to play the game. I don't see this message in any other Steam or non-Steam game I've played, so I think this is an Avorion check that no one else is doing. This is consistent across both the 1.x and 2.x lines. I've attached a screenshot of the warning message.

  • OS: Windows 10 Home
  • CPU: AMD Ryzen Threadripper 2950X 16-Core Processor    3.50 GHz
  • RAM: 32.0 GB
  • GPU: NVIDIA GeForce RTX 2080 Ti

I've searched the forums for the term "possible UI scaling issue" without finding anything relevant, and the few hits in DuckDuckGo aren't helpful, either. I've tried adjusting the properties on both bin/Avorion.exe and bin/AvorionServer.exe, combining on and off settings for each of the following settings, to no change in the warning message:

  • Properties > Compatibility > "Disable fullscreen optimizations"
  • Properties > Compatibility > Change high DPI settings > Program DPI
  • Properties > Compatibility > Change high DPI settings > High DPI scaling override
  • Windows Settings > Advanced scaling settings > Fix scaling or apps

No combination of these settings on these two executables makes the warning pop-up go away, so I'm kinda stuck on what to do at this point. Did I miss the one magic setting I need to set? Should I just chill out and click through the warning like I've been doing for almost a year? I'm not sure where this check is, well, checking, so I'm not sure how to appease it.

Thanks for a very fun game, my family and friends have spent a lot of hours playing it, and it's become one of our go-to games during the pandemic. Thanks in advance for any suggestions on how to get past this weird issue!

2021-10-06 18_32_06-Warning.png

Link to comment
Share on other sites

  • 2 months later...

This is a machine translation from Japanese, so I apologize if the translation is not correct.

I had the same problem in my environment as below.

  • Windows 10 Home
  • AMD Ryzen 9 5950X
  • RAM 32GB
  • GPU: NVIDIA GeForce RTX 3080

In my environment, by right-clicking on the desktop of the OS and changing the "Display Settings" under "Scaling and Layout" from 150% to 100%, the warning message stopped appearing. The warning message no longer appears.

Link to comment
Share on other sites

  • 4 months later...
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...