Jump to content

[SOLVED by new mod][1.1.2 Singleplayer] Product of Aluminium Mine of player faction is not updated Aluminum

Recommended Posts

Posted (edited)

[Edited 01: 2020/06/30 2005JST]

Since version 0.29, Aluminium is renamed to Aluminum.
This stopped producution network of Alliance which depends on Aluminum (formerly, Aluminium).

The cause seems to be followings:
1. Product of Aluminium Mine of player faction is not updated to Aluminum.
2. The following code does not cover this problem: "Goods.lua" goods["Aluminium"] = goods["Aluminum"] -- backwards compatibility

In case of AI factions, there was no problem because Alminium Mine was removed or changed into Aluminum Mine because of the following behavior.

You can fix this easily by simply visiting those sectors. Their factories will be updated into the galactic trade network and supply/demand prediction around them will correct itself.

The way to reproduce this problem is described below.
1. Prepare savedata made before Beta Branch 0.29 including Aluminium Mine of Alliance.
2. Load the savedata which meets the above condition in singleplayer or multiplayer.
3. Go to sector where Aluminium Mine of Alliance is located.
4. Interact and Trade Goods.
5. You will see Aluminium with always zero stock.

I have to apologize that my savedata is too big to attach.
By the way, I could find no way to change product of Aluminium Mine through Lua API in the Documentation... is there any way to solve this?

I hope this will be fixed.

Edited by struct_Nitori
SOLVED by new mod

Share this post

Link to post
Share on other sites
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...