Jump to content
SGS

I've lost all my ships within minutes

Recommended Posts

I'm so furious right now I can't tell.

I loaded up the game after a couple of days to try the new version, and right after logging in I found my main ship destroyed that was parked near an Equipment Dock. It has never happened to me before, it had 2M shields and 100+ fighters. Well, it was on a multiplayer server and I had a token of course, although I was quite bitter but I rebuilt it.

And then...my ships started getting attacked, and instantly destroyed by pirates! One by one! 7 miners, all the Key ships near the barrier, 1 salvager and 1 explorer ship, and some other smallers vessels, mostly idle. I've got at least 20 of my ships destoyed all over the galaxy within minutes!! It happened so fast I couldn't realize....

...WHAT IS HAPPENING??!

Share this post


Link to post
Share on other sites

dont be inside the barrier when someone kills the wormhole guardian. this triggers a counterattack .

Share this post


Link to post
Share on other sites

Hi there,

We made quite a few changes in the last major updates, that made the region within the barrier much more hostile.

Sorry that you got the full brunt of it and lost all your ships 😐  And thank you for reporting it, so that we could fix the issue!

As of Saturday the attacks on player ships shouldn't be able to happen all at once as you experienced. Now the AI will wait quite some time before attacking the next ship, so that you'll have more than enough time to get your ships to safety 🙂 

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...