Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.
Discord

Update 2.0 Out Now!

Update 2.0 now available! Check out the ton of QoL Features, improvements, captains, new commands and reworked UI!

[1.0 - 1.3.5] Ships temporarily cloning when moving to sector recently traveled by AI


TacticalMaster
 Share

Recommended Posts

I ordered my ships to move into a sector and I fast traveled there shortly after by "Move to Sector." Next thing that happened, there were "clones" of my ships in the system.

 

I have no idea why the game made duplicates of my ship. I just jumped into a sector that my ships recently traveled to and poof, comes doubles of my ship. RTS mode still detects them and the sector icon still counts all my ships and the "clones." Galaxy Map also counts my ships and the clones in the sectors, but the icons show my original ships and not the clones. I dared not to mess with these "clones" in the system, so instead I commanded via Galaxy Map where the game is able to identify my original ships. Once I was done in the system, I manually jumped into another system, and the clones disappeared in the sector. I didn't want to jump via fast travel [Move to Sector].

 

A byproduct of this bug is that my Ship Class names and Weapon Groups have *all* been reset. Torpedo Shaft weapon groups haven't been reset, for some reason.

 

This needs to be immediately addressed. It might be potentially game-breaking and thankfully I'm glad I didn't encounter any (yet), even if all my weapon groups and ship classes keep getting reset.

 

[8:32 PM EDIT] I'll put my logs just in case.

Clientlog: https://pastebin.com/1q9PZRQV (expires in 1 month)

Serverlog: https://pastebin.com/CFyY22YF (expires in 1 month)

(NOTE: For Clientlog, the event happened at 2020-03-28 17-06-52, containing sector (44:-36).)

(For Serverlog, the event happened at 2020-03-28 17-03-41.)

Edited by TacticalMaster
Version update
Link to comment
Share on other sites

I think this might be more serious than it looks. A player from an enemy alliance found a duplicate of my ship on our server today, and got instantly destroyed. He says the ship was moving very fast, dealt insane damage to his ship and the distance shown was very different from "visual" distance.

Link to comment
Share on other sites

  • 8 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...