Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.

Update 2.0 Out Now!

Update 2.0 now available! Check out the ton of QoL Features, improvements, captains, new commands and reworked UI!

[0.33.6] Cloned ships while ordering a ship in the same sector to jump


Recommended Posts

FULL TITLE: [0.33.6] Cloned ships while ordering a ship in the same sector to jump after exiting to drone


Um...how can I explain this?


I ordered one of my combat ships to head to a Resource Depot to refine scrap metal. I'm in the same sector and just exited into my drone so the drone is just about touching it. The game was not paused because ordering ships while within the loaded sector will not stack orders. It complied immediately and jumped into the waypoint empty sector, but when I exited the map, I noticed that the ordered ship was still in the same sector, and didn't jumped. I was like: "What?" So I decided to take control of the said ship and tried to move it myself, because the map locator isn't showing my ship on the map as opposed to the "other ship" that 'warped' ahead of it.


Upon reaching the intended Resource Depot location manually, I just noticed an oddity: There are TWO same ships at the same time! The ship was just about done refining and was being pushed away from the depot. I have no idea what is going on here, but decided to mess around in this oddity to see how serious it may be. So I went out of my drone and ordered my bugged clone (whatever?) ship(s) to jump into another sector to see how it plays out. There was only one dot on the map; the real ship. But who. After ordering to jump, I only notice that two of them jump at the same time. I took control of the ship in the same sector but I couldn't find the clone ship (or maybe it's hard using H targeting because I was allied with the faction). So I headed into a gate and back to the previous sector, but then the clone ship reappeared next to me.


I have no idea what's going on at this point. So I restarted my galaxy. After doing so, the cloned ship was still there. I ordered my ship to jump into the next sector but the cloned ship did not followed. I ordered the real ship to come back then tried again, but the cloned ship still stayed where it was.


At this point, I don't want to risk a game-breaking event, so I deleted the cloned ship -- in one go without leaving the ship editor. Seems like I can edit and build normally. But upon deleting my ship, the real ship disappeared from the map!! Most stupid decision ever. I warped into the sector of my real ship's last know position and saw that the ship was still there, next to the gate! But all in all, it's no longer showing on the map. Or even in my fleet.


I restarted the galaxy again, but while I was still in the real ship whose position disappeared from the map. After loading, the ship was still there and was back on the map! The only difference was that my Ship Reconstruction Crystal was missing for that ship and that my equipment was not the same. I just added 2 Exotic M-Turret Upgrade and XSTK-III after removing the Radar Upgrade, and my weapons are suspiciously lower grade. Oh well. I took the time to fix its setup.


All I was doing are typical things and micromanagement, then stuff happens. So other than what I was doing and messing around with this cloned ship bug, I have no idea how to reproduce this.


TL;DR Encountered a cloned ship after taking control of a ship that couldn't jump when the map showed it technically did and manually jumped into destination sector.


Before restart

Clientlog: https://pastebin.com/gWDb5bbE (expires in 1 month)

Serverlog: https://pastebin.com/3KanPpkB (expires in 1 month)


After restart

Clientlog: https://pastebin.com/LCRCb4Nd (expires in 1 month)

Serverlog: https://pastebin.com/adMtmEPt (expires in 1 month)


After restart x2

Clientlog: https://pastebin.com/G19Nvthn (expires in 1 month)

Serverlog: https://pastebin.com/4QHfknpK (expires in 1 month)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...