Jump to content
mpl560

[0.33.2] Critical bug - ship downgrades

Recommended Posts

I have sent one of my salvage ships to salvage wrecks in some sector i previously fought with my main ship.

I leave it to its own devices.

I have ordered some far away ships from the outer edges of galaxy to get near the barrier. To do that, some had to use wormholes.

 

When i inspected things at some point in the game, the salvage ship was at the wormhole sector. I did not send it there at all, the ship should have been at the battlefield location.

The same salvage ship with all its salvage-fighters and cargo was just GONE. Not destroyed. It was replaced by a ship version that it previously was.

Short story of that ship:

It was founded as some small ship, lets call it version 1A. I made some modification to it and it became 1B.

Then i replaced the entire ship with a new version from my saved designs, it became  2A.

What i have encountered at wormhole was 1B version of my ship.

 

There is something very wrong here.

 

This is how my ship looks like in the ship preview.

 

IZCJSJt.png

 

The red outlines indicate that it has missing blocks, but that is impossible. The ship in the picture shown by red outlines is a 2A version of my ship. It is a completely different blueprint from my saved designs. That's why the 1B version that is shown could not have missing blocks!

 

There is more to prove something is very wrong here. Cargo.

 

Q2gu1ZQ.png

 

On the left side the ship panel tells me that my cargo is empty. On the right side, the very same ship with different image preview has some cargo as i have highlighted.

 

You may read in the clientlog that the ship was never destroyed. Not to mention the wormhole sector had no repair docks to spawn ships from!

Clientlog

https://pastebin.com/xHEyPE7Z

Share this post


Link to post
Share on other sites

Thanks for the report. The good news is: That sounds like a ship duplication. I actually just fixed a bug related to this, so I hope that's what happened to you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...