Jump to content
Laserzwei

FPS drop with mods & ingame console-log

Recommended Posts

When enabling the ingame console-log (^) my FPS drop by 10-20% (only happened after its overhaul with multi-colors etc.)

 

I'm also affected by FPS loss when enabling mods. I observerd that this behaviour already occurs within the mainmenu. The FPS drop is correlates with the amount of mods enabled:

 

0 Mods:

 

 

yLj8bpp.jpg

 

 

 

 

1 Mod:

 

 

nAFbaFU.jpg

 

 

 

4 Mods:

 

 

swVSAxh.jpg

 

 

 

10 Mods:

 

 

nN45ArP.jpg

 

 

 

35 Mod:

 

 

LNJY2Oq.jpg

 

 

I also attached my settings, the first 72 Lines of the clientlog (for references to my hardware) and 2 profile jsons (one with and one without mods enabled)

Avorion_settings.zip

client-profile-mit-Mods.zip

client-profile-ohne-Mods.zip

Share this post


Link to post
Share on other sites

Thanks! Are those 2 profiles with the window closed or open? Can you please post one with all mods enabled and in-game and a reference one from in-game?Same sector, preferrably an empty one?

Share this post


Link to post
Share on other sites

Thanks!

1) Are those 2 profiles with the window closed or open?

2) Can you please post one with all mods enabled and in-game and a reference one from in-game?Same sector, preferrably an empty one?

1) Both profiles were made with the modselection window open

 

2) Sure:

https://www.dropbox.com/s/0nuu39cfrdw6xqp/Avorion%20profiles.zip?dl=1

 

With all mod enabled, I went down to 20FPS. And I noticed, with the help of the Frame Time Gaphs, that in semi-regular intervals a lagspike would occur. "client-profile-with-mods-no-cons-high.json" was made during such a lagspike.

With the console opened (and mods) it went down to 7FPS and keystrokes weren't registering properly anymore. That was really atrocious D:

"with-cons" == "consolelog was open"

Share this post


Link to post
Share on other sites

I can confirm that there is no noticeable performance decrease due to enabling mods anymore. Your fix works! Thank you  ;)

 

 

Share this post


Link to post
Share on other sites

I still have FPS drops, though they're not as big as before. I messaged screenshots and profiles in the Discord, koonschi.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...