Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.
Discord

Update 2.0 Out Now!

Update 2.0 now available! Check out the ton of QoL Features, improvements, captains, new commands and reworked UI!

[0.16.0] Constantly 100% server load


Hammelpilaw
 Share

Recommended Posts

Servers on version 0.16.0 got some issues with server load: even with 0 players online, and 0 sectors in memory, the server load is constantly at 100% when the galaxy is huge, the systems cpu usage keeps about 25%. Also there may sometimes be huge lags in game.

 

The server load is related to the amount (and maybe size, can't say) of already generated sectors. If you delete all sectors of the galasy and start the server again, the usage keeps <1% when no sector is alive.

 

I already reproduced this in a fresh vanilla galaxy: when there were about 100 sectors with npc factions generated, the server load was at 2% with no sector in memory.

 

Steps to reproduce:

  • Create a new galaxy at version 0.16.0
  • Print out server load with 0 sectors in memory: it will be 0%
  • Generate at least 200 sectors with some stuff in it (better 1000 or even more sectors)
  • Print out server load with 0 sectors in memory: it will be higher then 0 and get up to 100% when there are many generated sectors

This did not happen in 0.15.8.

 

We are using a Windows server, but I've talked to other server admins, using Linux, and they got the same issue.

Link to comment
Share on other sites

  • 1 month later...

So you're saying that server load increases for servers with lots of generated sectors, even when these sectors aren't loaded in memory?

Yes. The more sectors exist on hard disk, the higher the server load will be. Even when only one sector is in memory, server load increases up to 100% depending on the amount of existing sectors.

 

I do not know if it also depends on entities existing in these sectors or so. But the more sectors exist in the galaxy, the higher the server load will be. When you delete all sectors of a galaxy from disk, the server load will be <1%, even if it was constantly at 100% before you deleted sectors.

 

Link to comment
Share on other sites

Are we talking about windows or Linux servers here?

I only use windows, but people also confirmed this issue on linux.

 

My Windows Server is also on 100% load...

 

 

3 players online, in 3 sectors

4 players in memory, 65 registered

12 factions in memory, 508 registered

16 sectors in memory, 4968 sectors in total

Memory used by scripts: 231.4MB

Sectors Updated: 16

avg. server load: 100%

avg. update: 162 ms

max. update: 365 ms

min. update: 142 ms

Link to comment
Share on other sites

My server, too. Running on Windows.

After the update(s) 100% with 0 players online.

 

Server Version: Beta 0.16.6 r11134 6d77ebe1e8bc

after a fresh restart, and now "idling":

0 players online, in 0 sectors

0 players in memory, 6 registered

0 factions in memory, 195 registered

0 sectors in memory, 1256 sectors in total

Memory used by scripts: 2.92MB

Sectors Updated: 0

avg. server load: 100%

avg. update: 77 ms

max. update: 79 ms

min. update: 75 ms

Link to comment
Share on other sites

Are we talking about windows or Linux servers here?

 

Players are reporting to me that other servers are not playalbe anymore because of 100% load!

 

Please fix that as quick as possible... my server is loosing players and I don't want to wipe it ever 2-5 Days!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...