Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.

DLC Avorion Into the Rift Out Now!

Now available on Steam!

Ship goes mining when i leave


Recommended Posts

Howdy. Does anybody else encounter the problem, that when you leave your ship it launches all fighters as if its incontinent, thrusts away to the next asteroid field and begins mining  :o


The last time when i dropped out into my drone i collided with the side correction thrusters of my accellerating ship until i blew up and woke up in one of my fighters. Needless to say that the ship runs so fast ahead that it was in no time so far away because the fighter doesn't make a noticeable velocity :D


At first had a Captain aboard which i then fired but the ship goes wild even without a captain. Strange. The idle command didn't work at all.

Link to comment
Share on other sites

Now i have a captain again and entered my mine. The ship went into life and thrusted away again but now it began to spin around at v-max. I repeated the idle command but it didn't help  ::)


Would be nice if anyone have a solution for this behavior. Its kinda pain in the ass to boost behind the own ship after something to do outside. Luckily i got it everytime for now  8)

Link to comment
Share on other sites

Just a reply to make it not look like your question is getting ignored, but simply no idea what could be behind this...


Any mods installed that might interfere with each other?


Wanna post a .xml of the ship in question so ppl can test out?


Link to comment
Share on other sites

  • 2 weeks later...

So, downloaded your ship ("My ship is my best friend, my life, and i must master it as i must my life"), set it up with fighters, pilots, mining lasers and crew, and nothing unusal happened...


so i got a captian, ejected into drone and tried the mining command... as expected, the ship headed towards the next roid, launching all fighters in the process, and stopped when entering again... ok so far...


Then i tried to stop it renotely, as you pointed out the Idle-command didnt work (made the ship spin around at amazing speed!?), but Passive-Command made it stop mining and returned the fighters... good...


Now comes the tricky thing: When i gave the ship the mining command, and THEN fired the captain, i couldnt stop it since when i gave the passive command, it just said "No captain on the ship"! And it kept mining/launching... any chance THIS is what happened to you?


Link to comment
Share on other sites

Exactly. Thanks for your analysis. So the Ship comes to life if you leave into your drone and executes the last order even theres no captain on board.


As you wrote, the command without a captain results in the no-captain-message. I remember, i gave the mining command at first when i had no captain. Then i acquired a captain but didn't revoke the command. Later i fired him because i thought he went crazy but the ship still had it's strange behaviour...  This seems to be a minor bug to me but its managable,


At first i thought the ship would leave me alone in the void :D

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...