Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.
Discord

Update 2.0 Out Now!

Update 2.0 now available! Check out the ton of QoL Features, improvements, captains, new commands and reworked UI!

MAD scientist (no research ships/satellites)


Mcleod
 Share

Recommended Posts

Not sure if these 2 are related or not but only seem to have encountered them since latest beta version.

 

1. Not found any Mad Science labs/outposts at all (searched well over 100 sectors in right range), since I destroyed my 3rd one.

2. Been getting probably 2 out of 5 yellow blip sectors that are totally empty, not even a single asteroid or wreck.

Link to comment
Share on other sites

So I go to 0/150-240 start flying into yellow mass dots hoping one will pop up 127 later nothing at all not a single encounter! tell me i have messed up somewhere I can't find anymore info on this issue for me :(

Link to comment
Share on other sites

OK so after closing my game to come here and post i found that when i loaded back up the system i was in had a research sat for a few seconds then it vanished!

 

So i closed and loaded again and shot it...it doesn't vanish if you shoot it first odd bug.

Link to comment
Share on other sites

im having a simmilar problem. i try to find satelites for a long time now, without luck. what system where you able to make a sattelite spawn? was it an empty system, or did it have asteroids? will it be shown by the item finder?

im realy getting frustrated with these quests. without reading up on the wiki how they are supposed to work i was completely lost. i feel the game itself does a poor job in telling me what i am supposed to do.

 

Link to comment
Share on other sites

im having a simmilar problem. i try to find satelites for a long time now, without luck. what system where you able to make a sattelite spawn? was it an empty system, or did it have asteroids? will it be shown by the item finder?

im realy getting frustrated with these quests. without reading up on the wiki how they are supposed to work i was completely lost. i feel the game itself does a poor job in telling me what i am supposed to do.

 

System with asteroids yes -6/202 I think.

 

It does not show with the item finder.

 

And no the game doesn't really give enought "story" background or lore to help.

Link to comment
Share on other sites

There seems to be a (beta only?) bug, added a command that lets me trigger respawnresearchsatellite at will, and I can watch the sat spawn in, then despawn about 10 seconds later.

Adding DeletionTimer(satellite.index):disable() to the end of the Scientist.createSatellite function appears to fix it. Though no idea what else that'd might break, so experiment at your own risk.

Guess they're somehow considered wreckages and given a stupidly short despawn timer?

Link to comment
Share on other sites

  • Developer

Please post the server logs of the sessions when that happens. Best would be to start a session, try to provoke the lab, and when it doesn't work after 5 tries post the logs. Same for the hidden mass signature sectors. Oh and make sure with TAB that they're actually empty.

Link to comment
Share on other sites

There seems to be a (beta only?) bug, added a command that lets me trigger respawnresearchsatellite at will, and I can watch the sat spawn in, then despawn about 10 seconds later.

Adding DeletionTimer(satellite.index):disable() to the end of the Scientist.createSatellite function appears to fix it. Though no idea what else that'd might break, so experiment at your own risk.

Guess they're somehow considered wreckages and given a stupidly short despawn timer?

 

Sorry yes forgot to say i'm in the latest beta branch.

Link to comment
Share on other sites

Merged and moved topics about the MAD satellites. I have quoted koonschi's reply below, to bump it again.

 

Please post the server logs of the sessions when that happens. Best would be to start a session, try to provoke the lab, and when it doesn't work after 5 tries post the logs. Same for the hidden mass signature sectors. Oh and make sure with TAB that they're actually empty.

Link to comment
Share on other sites

Seems that's the same issue, again.

Jump to a non-generated sector I *know* is sectors/teleporter (added print x/y/generationTemplate to sectorspecifics), and ... absolutely empty sector.

Try another one. Again completely empty.

 

Slap a DeletionTimer(entity.index):disable() into the loop in teleporter.lua SectorTemplate.generate

jump to another one and ... hey look, there's the 8 teleporter roid stations.

 

For fun, change that to if i%2==0 then DeletionTimer(entity.index):disable() end

jump to another one and ... 4 teleporter stations (II,IV,VI and VIII).

 

It's like everything spawned via Sector():createEntity(...) ends up with a 10 sec despawn timer.

 

... or not. Playing around with it some more, creating them without a WreckageCreator component seems to also prevent them from insta-despawning?!?

 

Link to comment
Share on other sites

Oh thank the heavens! I cheated my drop for this because I gave up trying to find them! Lol

 

Can I ask How ?  My seed has the same problem and I'm stuck either outside the core or cheaty way in with a gate skipping the wall. I wanted to go in right this time but no mad scientist spawning

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...