Jump to content

Welcome to the Forum!

The best place to exchange builds and ideas! Vote for the best ideas and suggestions here.

Join the Avorion Discord!

Connect with other passionate players and talk about the latest news.

DLC Avorion Into the Rift Out Now!

Now available on Steam!

Major UI issues [Solved]


Recommended Posts

I'm loving the concept of the game so far, but I'm not truly able to play the demo because the UI is so badly disjointed. None of the text is actually ON the buttons or places it belongs, and actually pans around the environment at odd angles to the direction I turn the camera.


Win10, i7-6500U, GeForce950M, 12GB ram.


PLEASE HELP! I really want to give this demo a real try!

Link to comment
Share on other sites

  • Boxelware Team

Hi and welcome to the Forums!


We haven't had this issue before. Could you please post a screenshot? Press F12 ingame to take a screenshot, you will then find it in (your user folder)/AppData/Roaming/Avorion/Screenshots

Link to comment
Share on other sites

  • Boxelware Team

Thanks for the screenshots. This is odd. It looks like there is some kind of offset to the text. I'll need some more information to reproduce this.


Can you send me your client log? it's in located [your user folder]/AppData/Roaming/AvorionDemo/.


Some info I need to reproduce this:

- What window mode did you run the game in? Borderless/Windowed/Fullscreen?

- Does this problem appear with every window mode?

- Is the text static or does it move around? If both, what text moves around and what is static?

- Do you have more than one screen?


Link to comment
Share on other sites

I'll try answering in order, and the log will be attached.


The problem occurs in all window modes and resolutions, some are much worse than others, and sometimes just changing resolutions increases the issue.


The text pans around with the camera. As I turn the camera, the text moves around the screen. All text is affected.


I haven't tried this with additional screens.


Edit: Drivers are up to date as well.


Link to comment
Share on other sites

  • Boxelware Team

OpenGL Context Information:
Version: 4.4
Vendor: Intel
Renderer: Intel(R) HD Graphics 520
GLSL Version: 4.40 - Build

Your log file tells me that your computer is using the Intel on-board GPU, which is known to cause trouble. Can you switch to your NVidia GeForce950M and tell me if the problem persists?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...