Jump to content
NexusNull

[Mod][Beta] MineCorp

Recommended Posts

Hi guys,

Im having an issue with this where it will cause some sectors to crash unsure as to why. Is there some sort of debug trace available in avorion to figure out what is causing it to crash?

There also is an option in the server.ini file (something to do with "profiling"), which will pump out a txt file and an html file, which can be updated with more information with the /status command. It may or may not make the logs more verbose :).

Share this post


Link to post
Share on other sites

Hi guys,

Im having an issue with this where it will cause some sectors to crash unsure as to why. Is there some sort of debug trace available in avorion to figure out what is causing it to crash?

 

have you had any luck getting out of the crashing sector? i have a stuck player who's still crashing on load despite being teleported away >.<

 

Share this post


Link to post
Share on other sites

Hi guys,

Im having an issue with this where it will cause some sectors to crash unsure as to why. Is there some sort of debug trace available in avorion to figure out what is causing it to crash?

 

have you had any luck getting out of the crashing sector? i have a stuck player who's still crashing on load despite being teleported away >.<

 

What I know from experience when teleporting doesn't work it is either the ship itself that is bugged, or the player data.

I'm afraid I'm not aware of a way to fix that besides deleting the ship or the player data.

Share this post


Link to post
Share on other sites

Hi guys, ive gotten this mod to work using 1.6b and manually adding the code to both core game files. Theres one thing ive noticed however that loading this mod into existing galaxy's (especially if its from an older version of avorion) causes random crashes. Client log reports: Thread 1 Error: EXCEPTION_ACCESS_VIOLATION

 

Server log just reports that the player has logged off so it seems to be a client-side problem.

 

Income and Upgrades and other mod features work fine untill it just crashes.

 

So far on a clean new galaxy i havnt had said crashing problem.

 

Unless someone picks this mods development back up (im not good enough at lua to even know where to start) i would suggest using NerArth's Yet Another Mine.

 

All credit to NerArth for attempting to get this mod back on its feet and providing the (mostly) working 1.6b version.

Share this post


Link to post
Share on other sites

Hi guys, ive gotten this mod to work using 1.6b and manually adding the code to both core game files. Theres one thing ive noticed however that loading this mod into existing galaxy's (especially if its from an older version of avorion) causes random crashes. Client log reports: Thread 1 Error: EXCEPTION_ACCESS_VIOLATION

 

Server log just reports that the player has logged off so it seems to be a client-side problem.

 

Income and Upgrades and other mod features work fine untill it just crashes.

 

So far on a clean new galaxy i havnt had said crashing problem.

 

Unless someone picks this mods development back up (im not good enough at lua to even know where to start) i would suggest using NerArth's Yet Another Mine.

 

All credit to NerArth for attempting to get this mod back on its feet and providing the (mostly) working 1.6b version.

 

Can you post the complete client logfile? Wich Avorion version are you using?

In a very fast test it seemed to work in latest Avorion 0.17.1. Well I did not test enaugh to cause a random crash... but how you know its related to this mod? Could you also reproduce this in a fresh galaxy? Please tell what steps you did to cause the crash.

 

If it only happen in an old galaxy it may be a savegame issue, not an issue in the mod.

Share this post


Link to post
Share on other sites

Can you post the complete client logfile? Wich Avorion version are you using?

In a very fast test it seemed to work in latest Avorion 0.17.1. Well I did not test enaugh to cause a random crash... but how you know its related to this mod? Could you also reproduce this in a fresh galaxy? Please tell what steps you did to cause the crash.

 

If it only happen in an old galaxy it may be a savegame issue, not an issue in the mod.

 

See here for the issue I found with it.

 

See this for a similar issue someone else had.

 

I myself since attempting to fix the mod have found the same crashes, but I couldn't find where the problem was originating and I haven't had a look again since I simply decided to make my own mod instead. If you do find the issue do let us know, as I'd be very interested in understanding what caused it.

Share this post


Link to post
Share on other sites

See here for the issue I found with it.

 

See this for a similar issue someone else had.

 

I myself since attempting to fix the mod have found the same crashes, but I couldn't find where the problem was originating and I haven't had a look again since I simply decided to make my own mod instead. If you do find the issue do let us know, as I'd be very interested in understanding what caused it.

 

I can not reproduce this issue with Mod Version 1.6 by Laserzwei:

https://www.avorion.net/forum/index.php/topic,1607.msg24677.html#msg24677

 

Well I just watched your code... you are not using the latest version of this mod by Laserzwei wich fixed the issue you currently may have. Please use the version from link above. If you can reproduce the issue with this version please let me know, but it should work. At least you got a version that didnt work for lot of server owners wich endet up in crashes.

Share this post


Link to post
Share on other sites

I can not reproduce this issue with Mod Version 1.6 by Laserzwei:

https://www.avorion.net/forum/index.php/topic,1607.msg24677.html#msg24677

 

Well I just watched your code... you are not using the latest version of this mod by Laserzwei wich fixed the issue you currently may have. Please use the version from link above. If you can reproduce the issue with this version please let me know, but it should work. At least you got a version that didnt work for lot of server owners wich endet up in crashes.

 

Thanks, you're right; I did miss this version/reply even when I looked through the thread pages the first times. I'll be killing the links to my modified versions and I'll be checking out the code on that one for future reference.

 

Unfortunately, at least for me, in forum threads like this it's very easy to keep track of who posted what, so that's probably how I missed it. :(

Share this post


Link to post
Share on other sites

Seems like the mod doesn't work anymore. Atleast for me. It works, but when i click on 'I accept' option, nothing happends. I can click it 10000 times, still nothing will happen. And yes, i have enough money, and i tried coming to a dock and still nothing.

Share this post


Link to post
Share on other sites

I think there has been changes in game files wich broke the mod. I have a working version of this mod in my current modpack, wich is not public though. Maybe ill package it as a standalone mod and publish it inf forums in future.

Share this post


Link to post
Share on other sites

I think there has been changes in game files wich broke the mod. I have a working version of this mod in my current modpack, wich is not public though. Maybe ill package it as a standalone mod and publish it inf forums in future.

 

 

That would be awesome.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...